WOW - Special Pricing On All Lab Equipment. Check out our super low prices. Click Here
Shopping Cart Items: 0   Sub-Total : US$0.00
Welcome, Guest ( Login )
APS TechNotes See all articles

My water softener does not use salt What is wrong

My water softener runs, but does not use salt. The salt level hasn't changed in about 2 months. What would cause this?

1. You could have a salt bridge where salt forms a cavern and looks full but it is hollow.

Poke around in the salt tank with a broom stick to make sure that isnt it.

2. Remove the tube that goes to the brine tank, manually step the softener through all the cycles. At some point that tube will have suction on it. If it doesnt, then your head has a problem.

If it has suction but still doesnt draw salt, then maybe it is the timer not moving or engaging.

New control heads can be found here : Control Heads

New Water softeners can be found here : Water Softener Calculator








Full Site Search

Mini Cart

Your Cart Is Empty
Shipping is only $14.95
for most orders *
Laboratory Products Shipping

Need Help?

Contact Us>
818-786-0600

Lab Water Systems

Images are representative of the products. Images may or may not be of the actual product. If it is important e-mail us for an actual image if available.

* Flat Rate UPS shipping when able to ship via UPS and is in the USA excluding Hawaii and Alaska.
Larger Items may not be able to ship via UPS, in that case freight charges will be quoted seperately.
International shipping will be quoted after the order is placed. You will have the opportunity to cancel before we finalize your order.

Terms and conditions
Credit Application
Privacy Policy
Google Apps
List All Products